You are here

Error -6 attempt to upload to new Rocket with XW.v5.5.10-u2

18 posts / 0 new
Last post
k0tan
k0tan's picture
Error -6 attempt to upload to new Rocket with XW.v5.5.10-u2

I installed 17 RC1 on two PowerBeam M5's y'day no prob.

Today doing a Rocket M5 which I back-leveled to XW.v5.5.10-u2.  Boot tool says "good good". Downloaded from Release Candidates AREDN-3.17.1.0RC1-ubnt-rocket-m-xw-squashfs-factory.bin failure loading the file:

Firmware image check failed. Error code: -6

I downloaded the file again - same result when attempting to upload

I ran md5sum on the file - same result as with the file on the download page.  Help.
AE6XE
AE6XE's picture
How did you downgrade to XW

How did you downgrade to XW.v5.5.x?      It's significant that you do this from the AirOS UI.    The error you received might be explained if you had received a new Rocket that came with AirOS XW.v6.0.6.* , then "tftp" loaded AirOS XW.5.5.x.   tftp doesn't downgrade the boot loader, uboot, as needed to load AREDN.   I think the uboot version from XW.v6.0.6 will give you a firmware check error code like this.

If this is what happened, then from the AirOS UI, upload XW.v5.5.x one more time.   The good news is we have a fix in the pipeline so that the downgrade is no longer necessary.

Joe AE6XE

k0tan
k0tan's picture
Yes, Joe - I ran Uboot which

Yes, Joe - I ran Uboot which said bad good, then downgraded using AirOS UO to XW v5.5. Ran the tool which then said good good, and tried to upload the 17 - RC1.

AE6XE
AE6XE's picture
It should work with the steps

It should work with the steps you're doing, so scratching the head on this one.   Confirm the basics, AirOS version is "XM..." or "XW..."  and is "5.5.something".   I've seen ubnt posts that say firmware error 6 could be the wrong image  type.   Trying to remember if the check utility tells us what uboot version--is that shown?   Download of AREDN image is intact?  Try different browser, network cables, switch, and/or power brick--maybe image is somehow not uploading intact.  Power everything off, then on and try again.    Running out of ideas...

Joe AE6XE

k0tan
k0tan's picture
Uboot & error -6

Joe:
I rebooted my PC and unplugged the Rocket for a few minutes, then retried load - same -6 error
Tool currently says
  U-Boot 1.1.4-s776 (Nov 27 2013 - 15:58:45)
I did not screenscreen shot before using the tool, darn it!
I did a backup when I did the original BAD GOOD - do you think I need to restore?  I don't know how to do that...


 

AE6XE
AE6XE's picture
No need to restore anything

No need to restore anything from backup.   

OK, we are getting to the bottom of the issue.   This version of U-Boot is incompatible with AREDN firmware.   I'd speculate AirOS XW.v5.5.* is installed along side U-Boot 1.1.4-s776 (Nov 27 2013 - 15:58:45)?   Can you confirm?   

Before AREDN can be loaded we need to get the U-boot to this version:
U-Boot 1.1.4.2-s594 (Dec  5 2012 - 15:23:07)

Something didn't complete in a prior step.   The next step is to boot with AirOS running.   Then "upload" the XWv5.5.* ubnt fimware again.   When it gets to a prompt that says "update", grab a screen shot so we can confirm all the details.    After the upload, update, and reboot,  look to see if the U-Boot is downgraded to the s594 version.   We have to get to this version before proceeding.

Does the check tool give a GOOD GOOD with the U-Boot version U-Boot 1.1.4-s776 (Nov 27 2013 - 15:58:45)?  This would be a defect.

Joe AE6XE
  

k0tan
k0tan's picture
Update failed

Joe:
I grabbed a screenshot then tried to update.  About the time the progress bar got to the C in close, it went away, brief flast of some "Update..." message, and went back to login prompt, so something probably failed!  Tnx so much for your help.  Of course with the weekend on us, we'd like to get this node up on a tower!

 

Image Attachments: 
K5DLQ
K5DLQ's picture
i think you may need to TFTP

i think you may need to TFTP AirOs 5.6.x back onto it, THEN, AirOS GUI downgrade to 5.5.x
 

AE6XE
AE6XE's picture
I concur. The firmware check

I concur. The firmware check error may be due to the same AirOS version already running.

1) tftp upgrade to AirOs 5.6.x
2) boot, then in the AirOS GUI upload AirOS 5.5.x
3) boot and run check utility to triple check the correct version of Uboot is installed
3) in the AirOS GUI  upload AREDN
4) boot, (switch computer to DHCP) configure AREDN
5) pop open the bubbly and celebrate

We will all be elated when these hoops are no longer required -- in final 3.17.1.0 release.

Joe AE6XE

k0tan
k0tan's picture
Upgrade so I can downgrade

Joe - I've used FTP for decades and have it in cygwin on my PC.  I'll use it vs finding a tftp.
Double check my next steps:

  • Change my PC ip from 192.168.1.1 to 192.168.1.22  ???
  • Follow "Uploading firmware to Ubiquiti" to put the node in "recovery mode"
  • FTP XW.v5.6.15.30572.170328.1052.bin to / of the node using 192.168.1.20 ubnt/ubnt
  • Wait until node reboots
  • Change my PC IP back to 192.168.1.20
  • login, run boot tool and capture screen of tool and AirOS gui
  • use the gui to downlevel to XW.v5.5.10-u2.28005.150723.1358.bin
  • note the UBoot version. it should NOT be U-Boot 1.1.4-s776
  • If it's correct this time, and the updates complete correctly (FINGERS CROSSED) Load the RC1


 

AE6XE
AE6XE's picture
tftp and ftp are different

tftp and ftp are different protocols/handshaking.  It will only work with the tftp client -- a native windows tftp client is available out there.  There are directions for tftp process on this website in the install/download pages.

192.168.1.22 works fine (just something other than 192.168.1.20 on this 192.168.1.x network). 
leave the PC on 192.168.1.22 to access airOS, no need to change until going back to dhcp after AREDN is loaded.

Looks good.

Joe AE6XE  
 

k0tan
k0tan's picture
last question I hope..

Enabled tftp. I think this is the correct command line. Does TFTP prompt for uid/pwd?

tftp -i 192.168.1.20 PUT XW.v5.6.15.30572.170328.1052.bin /

k0tan
k0tan's picture
Not successful, I think

Sadly, I don't see any difference in the UBoot version, though no failure tftp install of 5.6 then gui install of 5.5.  Should I try installing the released AREDN or the RC1?

Image Attachments: 
k0tan
k0tan's picture
No joy

Thanks - did that but still wrong uboot version. Sigh.

AE6XE
AE6XE's picture
K0TAN,      Did these 5.5 and

K0TAN,      Did these 5.5 and 5.6 airos images both come from the links on the AREDN website?    We next need to isolate why uploading 5.5 in the 5.6 running airos is not correctly downloading uboot.  Let's validate the specific versions in use.   If these images didn't come from the links in AREDN, then repeat after obtain them.    Also, send me a email offline.  we might decide to test out a different/special firmware build to resolve this issue.

Joe AE6XE

k0tan
k0tan's picture
Email sent to arrl addy

Yes all from AREDN Software site.  Email sent.  With the wrong uboot, is there any reason to try to load RC1?

AE6XE
AE6XE's picture
Don't try to load the website

Don't try to load the website's RC1 with the wrong uboot.  this will leave things in an inconsistent state and nothing will boot up on the device.

k0tan
k0tan's picture
Solved and on the map

Thanks, Joe for all the help. Node is now at RC1 and on the map.

Theme by Danetsoft and Danang Probo Sayekti inspired by Maksimer